'Outbound HTTPS/SOAP connection'

Topics: Troubleshooting
Oct 15, 2010 at 9:11 AM


I would like to install composite cms on my localhost. But I can't solve the 'Outbound HTTPS/SOAP connection'. Do you have any idea? How can I install the Composite CMS on my localhost? I can't pass the next step called license. How can I soap my web server? I am using IIS 7.5. Thank you.


Oct 15, 2010 at 9:33 AM

Are you able to reach https://package.composite.net/Setup/Setup.asmx from your machine? The setup process will call the "ping" method to ensure that there is access to setup data.

Oct 15, 2010 at 9:36 AM

Yes I am able to reach the service from my machine..but the setup doesn't fire declaring the error  that I mentioned above...thank you

Oct 15, 2010 at 10:29 AM

Just checking - are you experiencing this problem right now? I'm asking because our hosting center was without Internet connection for 2½ hours about 11 hours ago.

Oct 15, 2010 at 10:39 AM


Yes it is Ok now..thank you very much..

Oct 25, 2010 at 6:33 AM


Can you tell me how the problem was solved? I am facing the same issue.

I installed a new certificate for the iis server but this did not solve the problem.

Oct 25, 2010 at 8:40 AM

This warning is not related to certificated on your own server - it means that the web server is unable to contact our setup service running on https://package.composite.net/Setup/Setup.asmx either due to restrictions (for instance a firewall) or a periodic problem at our end.

The web server should be allowed to contact an external website using HTTPS (port 443) using SOAP (web service). Could you check if you are able to load https://package.composite.net/Setup/Setup.asmx in a browser on the web server?

Oct 26, 2010 at 6:17 AM

I can access the service through my browser. When I tried it through visual studio it also worked. When I tried it from IIS it didn't. The assumption is that IIS needs to be configured to allow access for external sources. I thought it might need a certificate for ssl so I installed one. Still.. the same problem appeared.

Is there some resource I could follow for IIS configuration?

Oct 30, 2010 at 11:59 PM

Hi wskanaan

It is possible that the code is not executed under "full trust".

Which version of IIS are you using?

Jan 24, 2011 at 10:57 AM
Edited Jan 24, 2011 at 11:41 AM


I have same problem. My IIS ver.7.0 and Full trust for application is enabled.

https://package.composite.net/Setup/Setup.asmx from IE was opened successfuly.

Please help

Jan 25, 2011 at 8:59 PM

What are the plans to be able to skip this installation step, say you're sitting with a server without ANY internet connection?

Jan 25, 2011 at 9:23 PM

It is possible to set up a 'mock service' and reconfigure the Composite C1 site to use that instead of https://package.composite.net/Setup/Setup.asmx - here is how to:

Preparing the mock service:

  1. Download http://docs.composite.net/Downloads/CompositeSetupSite.zip
  2. Unpack "CompositeSetupSite.zip" to a directory
  3. Open the VS2010 solution CompositeSetupSite.sln
  4. Press F5 (run the website)
  5. Verify you have a service responding on http://localhost:7916/Setup/Setup.asmx
  6. (keep this website running)

Making Composite C1 use the mock service:

  1. Get a Composite C1 site installed (no need to launch web app yet)
  2. Edit the file /App_Data/Composite/Composite.config
  3. On line 558 (or close by) replace the value "https://package.composite.net" with the value "http://localhost:7916"
  4. Save the file
  5. Start the Composite C1 web app (restart if already running)
  6. Launch /default.aspx in a browser.
  7. The wizard starts - you should be all green now.

Note that the "Packages" feature inside the C1 Console will need access to https://package.composite.net/ so a lot of the fun is missing.

Jan 25, 2011 at 9:26 PM

You could also just make a "skip this step" feature!

Jan 26, 2011 at 10:03 AM

The reason this step is required is because all content is downloaded from the service when setting up the site. That is why it cannot be skipped.

Jan 26, 2011 at 4:37 PM

Content, which according to mawtex's last message, just as well could be retrieved locally, meaning that connection to https://package.composite.net is not strictly necessary to make setup a C1 installation the first time.

Jan 26, 2011 at 5:37 PM

Problem is that we would have to ship setup packages as part of the install, either bloating the download with a (release date specific) number of options or the 'bare bones' option. The latter option is no fun unless you are an experienced user. Also, the lack of access to the package server make things a bit dull.

But then again a "Outbound HTTPS/SOAP connection problem" block message on the startup sucks even harder.

What I would prefer is to find the source of this problem and fix it in C1 if possible or alert the user to a known fix, so users setting up Composite C1 will always have the full suite of starter sites and later access to the package server. If anyone reading this experienced this issue and found a fix, please share.


Feb 17, 2011 at 11:39 PM

Good news to those people who have been blocked by the "Outbound HTTPS/SOAP connection problem" message: This seem to be a proxy issue, where the asp.net app is not aware of the proxy settings on the local network and direct internet connections are not allowed. Browsers have the proxy settings, so proxy connections work, but not connections from IIS etc.

I have updated http://docs.composite.net/C1/Getting-started/Setup-check-failures.aspx?errors=connection with info on how to fix this issue. Any feedback on which config block worked is much appreciated, if you end up testing this.