Function Dialog Box Never Shows Up

Topics: General, Troubleshooting
Nov 24, 2010 at 2:34 PM
Edited Nov 24, 2010 at 2:36 PM

I'm getting pretty frustrated by the Composite Console now. So far, I have been able to workaround the problem, that most function dialogs never show up. But now I have just bumped into a situation where I need that dialog box.

The setup is simple. I have downloaded Composite, put it on a webserver running IIS 6.0. I have started the console, and chosen to use the Omnicorp sample website. I have also flushed given user "Everyone" full control of ALL files including subfolders and so on. I have flushed my cache and still I experience the problem.

I did not open the Composite solution in Visual Studio 2010 prior to publishing it the webserver. I downloaded the source files, and put them onto the webserver straight away. The installation is as fresh as it gets.

 

To give you a particular example to work with, here comes a step-by-step description of what I do.

1) I go to the Data scope.

2) Expand "Global datatypes".

3) Select "Omnicorp.Content.News".

4) Click "Edit Datatype"

5) Click the "Fields" tab

6) Select the "Content" field

7) Click the "Advanced" tab

8) Click the Widget type field. (I don't click the label, I do click the text which currently says "VisualXhtmlEditor...")

(OLD) Nothing happens, even when I do it from the very webserver itself.

(UPDATE) After waiting a long time, the dialog box came up, but without content. When I closed that dialog box, the value of the field had been reset to: "(no widget specified)...". I am still not able to change the value.

Fortunately an entry was added to the Server Log. The log entry reads:

Message : Widget settings reset. Existing widget failed to validate with the following message: 'Data at the root level is invalid. Line 1, position 1.'

Title : TypeFieldDesigner

EventType : Error

 

When I open "Help" -> "About Composite C1" it says that I am running Composite C1 2.0 SP1. Build no. 2.0.3947.24461.

I am using Firefox 3.6.12.

It does work if I execute it from within Visual Studio 2010. But I can't expect my client to do that when she is to maintain the webcontent.

 

 

Please help me!

Nov 24, 2010 at 3:16 PM

Would you be able to ZIP the website content and send link to "maw at composite dot net"? We have not experienced this before and would like to take a closer look.

Nov 30, 2010 at 2:40 PM

Thank you for being willing to look into this issue! I'm sorry for the late response, I have been away on holiday.

I've sent you an email, with the whole website zipped into one file.

Looking forward to hearing from you!

 

Dec 29, 2010 at 10:29 AM

Problem solved after moving the Composite website to IIS 7.5