No response when adding custom XSLT function

Topics: XSLT
Jan 23, 2011 at 10:46 PM

Unless there's something that I missed, there seems to be a problem when using your own functions in C1. I followed the YouTube XSLT tutorial to a T and when adding the function into a page, I can't seem to select and change any parameters. It's a strange problem.

Is there some additional step to "install" your own functions?

Here's a link to the screenshot:

The text box for the parameter doesn't show up.

This is in Firefox in Windows 7.

Jan 24, 2011 at 8:01 AM


Try to insert into the page content built-in Composite C1 function - for example "Composite.Constant.XhtmlDocument"  -  Is the problem reproduced?

Also, please, check this in IE browser.


Jan 24, 2011 at 6:19 PM

It works fine when I insert a built-in Composite C1 function. It also works when I imported the Composite.Media.YouTube function. I tested it in IE and it has the same problem. I don't know where to start when debugging as it doesn't show an error message... in fact, there's no feedback at all.

I can't click OK, it doesn't do anything. Cancel works, though.

Jan 24, 2011 at 7:56 PM

To debug your XSLT you can use Debug properties on the "Settings" tab, specify test values for the Input parameters and select "Preview" tab to see the output result.

I could not reproduce this issue. I also use Firefox and Windows 7.

In order to make sure that the problem is not in your YouTube function, please, try to add simple XSLT function with one string Input parameter. Select "Preview" tab to make sure that the function works. Then try to insert this simple function into the page content and specify value for the input parameter.

Jan 25, 2011 at 9:07 PM

The strange part is that it WORKED in the preview window. The ONLY thing that didn't work was the visual parameter picker. I could manually type in the function code with the parameters and it would work.

Anyway, I did a new function, copied and pasted the values and it still had a problem.

Then, I did a simple XSLT function and it worked.

So... then, I did a simplified YouTube function with only the Video ID as a parameter and it worked. Then I added each parameter. The only difference between this and the original now is that I didn't add any test values. Strange... but it works now. I wish I could know what the problem was, though!!!