composite namespace error

Topics: Troubleshooting
Mar 4, 2011 at 11:37 PM

Here is a weird error I am geting. I downloaded the Composite C1 2.0 SP1 (2.0.3947.24461) project file with the default Omnicorp solution and I am running composite in visual studio 2010. Everything compiles and works great in visual studio. When I publish to my server which is running iis 6, I get this error when trying to view the website...

Server error in '/'Application

Compilation error

Description: The type or namespace name 'Composite' could not be found(are you missing a directive or an assembly reference). Here is the error list from my Default.aspx file.

Line 5: <%@ Import Namespace="Composite" %>

Line 6: <%@ Import Namespace="Composite.Data" %>

Line 7: <%@ Import Namespace="Composite.Core.Configuration" %>

All of these 3 lines of code at one time, bombed out and threw an error.

Has anyone had an issue similar to this??

Mar 5, 2011 at 12:21 AM

What is the content of the /bin folder on your server? The error is typical if Composite.dll is missing.

Mar 5, 2011 at 12:29 AM

If I run the site from inside visual studio, everything works great. I have all the dll files. Everything compiles and works just fine. As soon as I publish from visual studio, I run into problems.

Mar 5, 2011 at 12:34 AM

Yes, i do understand that. Thats why im asking you to actually, by yourself, take a look in /bin folder on the server after you've published.

Coordinator
Mar 5, 2011 at 5:12 AM
Is the site running in a subfolder, and if so have that folder been configured as an virtual app in IIS?
________________________________
From: ldoran
Sent: 05 March 2011 01:29
To: Marcus Wendt
Subject: Re: composite namespace error [CompositeC1:248507]


From: ldoran

If I run the site from inside visual studio, everything works great. I have all the dll files. Everything compiles and works just fine. As soon as I publish from visual studio, I run into problems.

Read the full discussion online<http://compositec1.codeplex.com/discussions/248507#post575864>.

To add a post to this discussion, reply to this email ([email removed]<mailto:[email removed]?subject=[CompositeC1:248507]>)

To start a new discussion for this project, email [email removed]<mailto:[email removed]>

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings<https://compositec1.codeplex.com/subscriptions/thread/project/edit> on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com
Mar 9, 2011 at 8:34 PM

Somehow the website was setup wrong in iis. I was able to finally get the site running. Here is what had to be done...

Install .Net 4 on the Server hosting IIS and restart the server.

Copy the file and folders that are housing the web site to C:\Inetpub\www\

Grant local accounts  ASPNET and Network Service full control to the folder and sub-directories

Verify that .Net 4 is enabled

  • Go to command prompt and type C:\Windows\System32\cscript iisExt.vbs /ListFile
  • Locate 1 C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll
  • If the 1 is a 0 the run the following... C:\Windows\System32\cscript iisext.vbs /EnFile C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll

Register .Net 4...paste this in command prompt... %windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe /i

Make sure asp.net 4 is allowed on iis... Use the IIS Manager to do this. Locate the 'Web Service Extensions' folder. Make sure 'ASP.NET v.4.0.30319' is set to 'Allowed'

Make sure that the default home page has been selected and ensure that you are running a virtual application.

Thank you very much to everyone that contributed to helping me resolve this issue.