Installing the SQL Provider - how to

Topics: General, Release notes
Mar 9, 2011 at 1:03 AM

For the fellow 1'ers that have been looking for our sql server data provider - but haven't found it:

Sep 2, 2011 at 7:58 PM

Hi All,

I migrated my website from XML-based to SQL based in my development environment.

Then i added some changes.

Now i need to copy the site to production. Production is still XML-based.

Before i just copied website folders from development to production.

How it should be made correct now? For example connection string is different (as min server name).

Thank you.

Sep 2, 2011 at 8:07 PM

And - can i migrate back if needed?

 

Sep 5, 2011 at 7:56 AM

Hi Olga,

Please check this http://docs.composite.net/C1/Data/DataFAQ.aspx?q=How+to+back+up+and+restore+an+SQL-based+website%3f

/Vitaly

 

 

Sep 5, 2011 at 8:27 AM

Vitaly, thank you.

I need the answer to the question about migrating from SQL to XML. Is it possible?

Sep 5, 2011 at 8:29 AM

http://docs.composite.net/C1/Packages/CompositeC1Tools/CompositeToolsDataStoreMigrator.aspx

Please see the section called "Migrating the data store From SQL to XML"

Sep 5, 2011 at 8:32 AM

So to sum up :)

XML to SQL :  http://docs.composite.net/Composite.Tools.SqlServerDataProvider
SQL to XML:  http://docs.composite.net/Composite.Tools.DataStoreMigrator

/Vitaly

Sep 5, 2011 at 8:42 AM

Thank you!

When i copy website from development and production server - i can use backup/restore.

Then i need to change for example connection string.

Is it enough to change it in ~App_Data\Composite\Composite.config?

Mat be something else should be changed too?

Sep 5, 2011 at 9:06 AM

If you totally replace your "production" website with the SQL-based "development" website,

you should

  1. Copy the "development" website to the "production" environment (totally replacing the files there). [You can either zip the website manully or use our XML Based Site backup package.]
  2. Back up the "development" database and restore it into the "production" database.
  3. On the "production" server, change the connection string in ~App_Data\Composite\Composite.config

 

/Vitaly

Sep 5, 2011 at 9:08 AM

Vitaly, thank you a lot :)