Error when installing SqlServer Data Provider if site is running in a virtual folder

Topics: Troubleshooting
Mar 10, 2011 at 10:53 AM
Edited Mar 10, 2011 at 10:59 AM

Hi all!

I've been evaluating the composite cms and I just installed the latest nightly build via the Web Platform installer. The reason I did so was to obtain the SqlData provider for moving the site from xml to sql based data structures. 

When installing the data provider it can't find the nessacary xslt file. I've checked the path and it seems the app name is being repeated in the path for the xslt. I've tried this a couple of times now with the same result. I even uninstalled the application from IIS and did a completly fresh install with the same results. 

Here's what I used to install via IIS

Website : New website
Application Name : C1app
WebsiteName : CompositeC1
Physical Path: C:\source\C1cms
Ipaddress All unassigned

And this is what I get on the connection string screen on the SQLServer Data Provider

Could not find a part of the path 'C:\source\C1cms\C1app\C1app\Composite\InstalledPackages\content\views\Composite.Tools.SqlServerDataProvider\SetDynamicSqlDataProvider.xslt'

The path 'C:\source\C1cms\C1app\Composite\InstalledPackages\content\views\Composite.Tools.SqlServerDataProvider\SetDynamicSqlDataProvider.xslt' would work. It's the extra C1app which is messing this up. But where is it coming from?

I'n running version CompositeC1WebPI 2.1.4085.24480 Release Build 20110309 and installed via Web platform(the only way to get the latest builds) into IIS.

Thanks

Richard

p.s.

Also when setting up I put the connection string in, then I have to authenticate THEN put the connection string again. Bit weird.

Mar 11, 2011 at 11:17 AM
Edited Mar 11, 2011 at 11:18 AM

Thanks for the excellent details - turns out that running the website in a IIS virtual application (sub folder) provoke an issue. We will fix this in the package and get it online asap, but you can continue by implementing this change:

Edit ~\Composite\InstalledPackages\content\views\Composite.Tools.SqlServerDataProvider\SqlDataDataProvider.aspx.cs

Replace line 161:

              var xsltPath = PathUtil.Resolve("~" + Path.Combine(this.TemplateSourceDirectory, xsltName));

 With:

              var xsltPath = this.MapPath( xsltName );

About the authentication stuff - could you provide more info on this? Are you required to do a Windows Login? 

Mar 11, 2011 at 1:29 PM

Hi, RSWright

The package Composite.Tools.SqlServerDataProvider has been fixed and is online now. (version="1.0.5")