Template CSS/IE problem

Topics: Troubleshooting
Mar 16, 2011 at 1:10 PM

I have a problem which appears to be a css problem but I am not convinced. I have a HTML/CSS template and have adapted it to use with C1. The problem is the template seems to align itself to the left when viewed in Internet Explorer, Firefox/Chrome are fine, the following images will give you more of an idea:

The first image is the template in its original HTML viewed in Internet Explorer - http://www.mihia.eu/cc1/html-ie.png 

The second image is the template in C1 viewed with Internet Explorer - http://www.mihia.eu/cc1/c1-ie.png 

The third image is the template in C1 viewed with Firefox - http://www.mihia.eu/cc1/c1-ff.png 

For refrence here is the template/css files - http://www.mihia.eu/cc1/code.zip

Its worth noting that the same thing has happend with every HTML/CCS template that I have tried - 3 in total, all appear aligned left with CSS problems in IE whilst working fine in Firefox/Chrome.

If anybody can shed any light I would be most grateful.

Coordinator
Mar 16, 2011 at 1:27 PM

I guess that adding  <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> to the template should solve the issue.

Mar 16, 2011 at 1:41 PM
Inna wrote:

I guess that adding  <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> to the template should solve the issue.


I had thought of adding that but for some reason never got round to trying, anyway that solved the problem, thank you.

Coordinator
Mar 16, 2011 at 1:46 PM
Edited Mar 16, 2011 at 1:47 PM

This is IE issue with "MARGIN: AUTO"  CSS rule and adding valid DOCTYPE solve this issue.