C1 2.1.3 with Blog Package errors

Topics: General, Troubleshooting
Aug 1, 2011 at 7:42 PM

Hi,

I upgraded to 2.1.3 on my site with the Blog Package already installed and the blog doesn't work. Before, the detail pages for the posts would just redirect back to the blog home page. Now, the detail pages, archive links, and tags give a 404 error. The link URLs are all correct. I tried updating the CompositeC1Contrib package, but that only gave another error:

 Could not load type 'CompositeC1Contrib.Web.UrlFilterModule' from assembly 'CompositeC1Contrib'

I removed the above reference from the web.config, but the blog is still giving 404 errors. I followed all the directions here. I tried clearing the browser cache and rebooting the server, but no luck there. Can anybody help?

Thanks,

-Naibla

Aug 2, 2011 at 7:18 AM

Hi naibla,

Have you updated the Blog's dll as described here http://compositec1.codeplex.com/discussions/264105 in Step 5?:

5)      If “Composite.Community.Blog” ... installed, download and replace related dlls:

 http://docs.composite.net/Downloads/Temp/2.1.3Beta2/Composite.Community.Blog.dll

/Vitaly

 

Aug 2, 2011 at 7:30 AM

Could you please also give some details on versions/builds and the setup - where possible?

  1. What is your current Blog's version?
  2. What is you current C1 2.1.3 build (Help > About Composite C1 > Build no.)?
  3. What build/version of C1 did you upgrade from? Was it the official v.2.1.1 (Build no. 2.1.4113.99) or one of the intermediate 2.1.3 builds?
  4. How did you install CompositeC1Contrib on your website? a) Used http://compositec1contrib.codeplex.com/, build, installed and configured it manually, b) Selected the "Master Pages" option of the Starter Site when installing a C1 site, c) installed the C1Contrib package (http://docs.composite.net/C1/Packages/Contribution/CompositeC1ContribCore.aspx) in System > Packages > Available Packages?

Thank you in advance

/Vitaly

 

Aug 2, 2011 at 9:38 AM

naibla,

I have just reproduced the issue you described. It is reported and should be fixed in the next builds.

Sorry for inconveniences

If there is a workaround coming up, we let you know.

/Vitaly

 

Aug 2, 2011 at 9:53 AM

@wysocki so what IS the issue?

Aug 2, 2011 at 9:56 AM

@naibla since Composite 2.1.3 now natively supports configuration of how you want your url's to look like, CompositeContrib doesn't need its UrlModule anymore. That is why you got that error when upgrading, and the correct thing to do is as you did by removing it from web.config.

Aug 2, 2011 at 10:05 AM

I updated the package, removing reference to "UrlFilter" in your web.config should solve the problem

Aug 2, 2011 at 10:19 AM
burningice wrote:

@wysocki so what IS the issue?

"the detail pages, archive links, and tags give a 404 error."

In short,

If you run a website 2.1.1 with Master Pages (say, you installed a Starter Site with the Master Pages option) + Blog,

then manually upgrade to, say, the latest 2.1.3 and also upgrade CompositeC1Contrib package (disregarding and manually fixing the UrlFilter errors that you can get along the way), and Blog

your blog post details, archive and tag links stop working - you get  404 errors.

We assume that something wrong might be in the Blog package. BUt this will require some investigation.

/Vitaly

 

 

Aug 2, 2011 at 1:53 PM

The issue was reproduced and fixed. Way to fix:

1) uninstall CompositeC1Contrib package

2) download and install a newer version from here

http://c1packages.codeplex.com/SourceControl/changeset/changes/8618

/Contribution.CompositeC1Contrib.Core/Release/Contribution.CompositeC1Contrib.Core.zip

Aug 2, 2011 at 2:48 PM

Thank you everyone! It's working perfectly now.

-Naibla