composite c1 not working on IIS7

Topics: Troubleshooting
Aug 5, 2011 at 1:14 PM

Hi guys,

Can you please assist me with my problem, I can't open composite page on my composite projects, I migrated my site from dev machine1 to dev machine2 windows server 2008 IIS7 heres the error:

Module IIS Web Core
Notification BeginRequest
Handler Not yet determined
Error Code 0x80070032
Config Error The configuration section 'system.serviceModel' cannot be read because it is missing a section declaration
Config File \\?\C:\inetpub\c1test\Composite\web.config
Requested URL http://localhost:80/Composite/top.aspx
Physical Path C:\inetpub\c1test\Composite\top.aspx
Logon Method Not yet determined
Logon User Not yet determined
<fieldset><legend>Config Source</legend>
   82:   <system.serviceModel>
   83:     <services>

Server is fresh install, I've already installed 4 and windows update, IIS features are also complete.



Arnel Gracela

Aug 5, 2011 at 3:21 PM

Hi Arnel

Check that your site is running under .NET 4.0.

Aug 5, 2011 at 5:44 PM

Yeah, I installed that and restarted the server but have the same problem.



Aug 5, 2011 at 5:47 PM

its not enough to install .net 4.. it can run side by side with .net 2, so you need to explicit tell each website which version of .net to use

Aug 5, 2011 at 6:33 PM

yeah, the c1 site is using .net 4 i'm very sure of it, what else can i look at, thanks for the help



Aug 5, 2011 at 6:42 PM

You have been in iis and checked the version for your application pool? this error only makes sense if you're using .net 2 for your application.

Aug 5, 2011 at 7:02 PM

Yeah, its really weird, I've installed a fresh and empty c1 project and assigned v4 app pool to it but same error, any c1 site i put here had the same problem.




Aug 5, 2011 at 8:34 PM

Don't know if it mattes, but is it running in integrated or classic mode?

Aug 6, 2011 at 3:17 AM

its integrated mode

Aug 6, 2011 at 10:10 AM

Any chance you can dig out other error messages? So far I'm not recognizing anything.

Did you set up the /Composite folder as an app (if so, make it a std. folder again). Is the front-end running okay? Are all bits you use installed (like MVC3)? Are file permissions okay (write access to /App_Data as a minimum)?

Also you could try to hook up the log reader and see if the is more info there (the error you see could be secondary). Probably you need to dig out the physical log files and open them as files via the log viewer - the files live in ~\App_Data\Composite\LogFiles

Aug 8, 2011 at 4:49 AM

Hi mawtex,

Its not creating any entries on the LogFiles folder, but I found the solution, Its the .net framework 3.0, I enabled framework 3.0 on the features, it changes the error to:

Could Not Load Type 'System.ServiceModel.Activation.HttpModule'

I think .net 3.0 overrides the installed .net 4 so i run this to re-register the .net 4:

went to .net 4 folder (c:\windows\\framework\v4.0.30319) using cmd with admin rights and execute

aspnet_regiis.exe -iru


Thanks everyone for your suggestions.


Arnel Gracela