Forms Renderer

Topics: Standard packages
Sep 12, 2011 at 9:27 AM

Hi there!

I am trying to use the Forms Renderer Function but it seems to have dissapeared from my site during the migration from XML based site to the MSSQL dito.

I seem to remember that I had some error with the migration caused by the Forms Renderer Function but since this took place some time ago and I am getting quite old I am not sure =)

So what to do, I can't find among the Installed packages in my site and I can't find it in the Available packages is it possible to download and install a separate package locally?

Best Regards Krezz

Sep 12, 2011 at 9:43 AM

Hello,

Do you see Composite.Forms.FormRenderer package under the System/Packages/Installed packages ?

Sep 12, 2011 at 9:49 AM

Hi there!

No I can't see it and I even tried to use the function just to determine if it is installed and just "hidden" but it was not found hence throwing an error.

Best Regards Soren

Sep 12, 2011 at 9:58 AM

Information about installed packages stored here ~\App_Data\Composite\Packages\{package_ids_folders}. Composite.Forms.FormRenderer has Id = 6fe2ef97-15e6-4aca-a1e3-588d770b435b . Do you have folder with title "6fe2ef97-15e6-4aca-a1e3-588d770b435b" under ~\App_Data\Composite\Packages\ ?

 

Sep 12, 2011 at 10:15 AM

Hi there!

No such folder found =(

Best Regards Soren

Sep 12, 2011 at 10:43 AM

It looks like Forms.Renderer is not installed. Online available module has minimumCompositeVersion="2.1.4246.22572" , so if your site is running on 2.1.1. version, you will not see this package under Available packages. You can download  2.1.1 compatible version from here - http://packagesdemo.c1.composite.net/uploads/Composite.Forms.Renderer.zip  and then install it as Local package -> System -> Packages -> Installed packages -> Local packages -> right click "Install local package"

Sep 12, 2011 at 10:49 AM

Hi there!

Thank you very much for this solution I'll give it a try asap.

But how about upgrading the Version of the site?

Best Regards Soren

Sep 12, 2011 at 10:51 AM

Upgrade steps are described here - http://compositec1.codeplex.com/discussions/264105

Sep 15, 2011 at 9:42 PM

I have a C1 version 2.0 SP 1 Build no. 2.0.3947.24461

I have installed several Composit.Forms.FormRender on this version

This C1 I downloaded from the web platform installer sometime i June. Now I want to install the Forms package and it is not available :-(. How do get it or how do I upgrade to 2.1.xxx

Best regards

Sep 16, 2011 at 8:59 AM
Edited Sep 16, 2011 at 8:59 AM

Hello,

The minimum Composite version should be "2.1.4113.99" (current release build)

>> how do I upgrade to 2.1.xxx

Upgrading 2.0 SP1 -> 2.1 

Upgrading C1 2.1 -> 2.1.1

 

>> How do get it

upgrate your site to the official release or you can find this package on the solutions where you have installed it (2.0 SP 1) - ~\App_Data\Composite\Packages\6fe2ef97-15e6-4aca-a1e3-588d770b435b\package.zip - install it as Local package

Sep 19, 2011 at 7:56 AM

Tnx a lot. I'm up and running.......