New setup: Failed to load assembly DotNetOpenAuth

Topics: General
Jul 24, 2012 at 8:39 AM

Just installed, but I get this error in log, any idea how to fix it, or is this ok?

20120723 18:34:28.1718 3 23 Error DataTypeTypesManager  System.Exception: Failed to load assebmly 'DotNetOpenAuth, Version=4.0.0.0, Culture=neutral, PublicKeyToken=2780ccd10d57b246' ---> System.IO.FileNotFoundException: Could not load file or assembly 'System.Web.Mvc, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

Developer
Jul 24, 2012 at 11:26 AM

Hi!

I assume that you've installed the "Composite.Community.OpenID" package.

This is a known issue caused by "a soft reference to some MVC related DLLs" (I am quoting from the earlier investigation into it).

As it doesn't cause any problem other than those errors in the log (does it?), its current status is dubbed 'as designed'. But we will certainly look into it further.

/Vitaly

Jul 24, 2012 at 3:30 PM

Thanks for the clarification, I just don’t want to have unknown errors in the log.

Thanks for your time answering this question.

 

 

Sep 16, 2012 at 1:34 PM

Hi, got the same problem, but in worse scenario.

Server Error in '/' Application.

Could not load file or assembly 'DotNetOpenAuth.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=2780ccd10d57b246' or one of its dependencies. The system cannot find the file specified.

 

Problem appears after (as I understood) opening project with Visual Studio 2010. And also I didn't install the Composite.Community.OpenID package or something else. It's a my first c1 website that I want to publish into web, and got a lot work with it, please help bring it up and running.

Developer
Sep 17, 2012 at 6:12 AM

Hi!

Can you provide more detailed info:

What's your environment (OS, web server, Composite C1 version/build no., website template if initialized, any packages installed, any custom code added)?

What's your step to reproduce the issue (like 1) get v.3.2, 2) open it in VS 2010, 3) Press F5 to run the website....)?

/Vitaly