Navigation does not translate

Topics: XSLT
Oct 19, 2012 at 5:48 PM
Edited Oct 19, 2012 at 6:52 PM

Using the Language Switcher between English and French, I found that randomly the navigation will switch between the two languages.

I'm using Composite.Navigation.Distributed for navigation and Composite.Navigation.LanguageSwitcher to switch between languages. When browsing the French portion of the Site, all the sudden the navigation is back to English, randomly. The content and the URL is still showing correct French translation, except for the navigation. -- and other way around.

 

This happens on both the server and local (Visual Studio). I hoping this is something wrong with my setup!

Clearing browser cache does not fix the problem.

Please, help.

Coordinator
Oct 22, 2012 at 7:37 AM

Hello,

What C1 version, Composite.Navigation.Distributed and Composite.Navigation.LanguageSwitcher version do you use?

Do you use Razor or XSLT version for the Composite.Navigation.Distributed and Composite.Navigation.LanguageSwitcher modules?

Oct 22, 2012 at 5:04 PM

Inna,

 

I'm running the latest version of C1: 3.2 Patch 1. Composite.Navigation.Distributed.XSLT: 1.1.8 and Composite.Navigation.LanguageSwitcher.XSLT 1.4.2.

 

Thanks!

Coordinator
Oct 23, 2012 at 11:16 AM

@clayhenry thanks for bringing this issue to our attention. We are investigating this issue at the moment and so far it looks like at bug introduced in 3.2 Patch 1.

Until we have a patch addressing this issue you can solve the issue by forcing C1 Functions running on your page to execute sequentially:

  1. Edit ~/App_Data/Composite/Composite.config
  2. Search for these two lines:
    <add name="Functions. Executing nested function calls" enabled="true" />
    <add name="PageRenderer. Embedded function execution" enabled="true" />
  3. Change "true" to "false" so the lines look like this:
    <add name="Functions. Executing nested function calls" enabled="false" />
    <add name="PageRenderer. Embedded function execution" enabled="false" />
    
  4. Save the config file
  5. Restart the website, for instance by using Tools | Restart Server from within the C1 Console

 

Marcus

Coordinator
Oct 25, 2012 at 9:31 AM

@clayhenry we have released at patch that fix the issue - the install steps are pretty simple, read more here http://community.composite.net/C1/Blog/2012/10/25/Patch-3-available-for-Composite-C1-32

If you used the work around described above you can roll back the changes.

Oct 25, 2012 at 4:13 PM

This is why Composite C1 is the best CMS! Thanks.