Problems with CphCloud.Packages.UrlAlias

Topics: General, MVC, Standard packages, Troubleshooting
May 10 at 6:43 AM
We have used the above mentioned package in our C1 CMS installation. There are 2 problems we are facing:
  1. We use Git to handle our source code. Unfortunately the UrlAlias package ist not active when a new dev clones the repository. The package files are there and it is listed as active in the administration but startup of the cms fails because the module entry pointing to the dll crashes. I think we there is a problem with our gitignore and we are missing to check in some files that are needed but I have no idea which ones? Here's our gitignore:
Artifacts/*/
CompositeC1PackageBuilder/*/
/App_Data/Composite/ApplicationState//*
**/App_Data/Composite/ApplicationState/SerializedConsoleMessages/ConsoleMessages.xml
*/App_Data/Composite/Cache/
**/App_Data/Composite/DataStores/Composite.Data.Types.IUserConsoleInformation_Published.xml
*/App_Data/Composite/LogFiles/
**/App_Data/Composite/DataStores/Composite.Data.Types.IFlowInformation.xml
**/App_Data/Composite/DataStores/Composite.Data.Types.IFlowInformation_Published.xml
**/App_Data/Composite/DataStores/Composite.Data.Types.ILockingInformation.xml
**/App_Data/Composite/DataStores/Composite.Data.Types.ILockingInformation_Published.xml
**/App_Data/Composite/DataStores/Composite.Data.Types.IUser.xml
**/App_Data/Composite/DataStores/Composite.Data.Types.IUserConsoleInformation.xml
**/App_Data/Composite/DataStores/Composite.Data.Types.IUserDeveloperSettings.xml
**/App_Data/Composite/DataStores/Composite.Data.Types.IUserFormLogin.xml
**/App_Data/Composite/DataStores/Composite.Data.Types.IUserSettings_Published.xml
**/App_Data/Composite/DataStores/Composite.Data.Types.IUserUserGroupRelation.xml
**/App_Data/Composite/DataStores/Composite.Plugins.WebClient.SessionStateProviders.DefaultSessionStateProvider.ISessionStateEntry_Unpublished.xml
  1. Uninstalling the UrlAlias for these new devs fails. We remove the module entry from the web.config which allows to start the cms. Then we navigate to the administration where the package is listed as active. But uninstalling shows "parameter <referencedType> cannot be NULL". Too bad because reinstalling the package would solve the issue...