How to deploy the site from local to www

Topics: Troubleshooting
Oct 15, 2010 at 2:13 PM

I have just downloaded Composite C1 CMS and it works fine. I have made my own templates and are pretty happy :-)

How can I move the local site from my local pc to a webhotel? I have tried to Publish the site by using the Publish button in WebMatrix - but it seems like I need to do some other actions in terms of getting it to run.

Can you help me?

/Peter

Coordinator
Oct 15, 2010 at 3:07 PM

Are you getting any errors? If you do please post the whole enchilada.

Oct 15, 2010 at 7:52 PM

I have published the local version to a sub domain on my website - and this is the error message i'm getting:

Server Error in '/' Application.

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine. 

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>

Does that give you a clue?

/Peter

Coordinator
Oct 15, 2010 at 9:24 PM

Are you able to change the content of the /web.config file and re-upload? If you are, try to do the change suggested in the error above. This will show the "real" error message and should sched some light on the situation.

Keep a backup of the unmodified web.config file and revert to that one later - showing "real error messages" is nice when debugging, but should be turned of when running normally (since it's a potential security risk - diclosing way to much details to anyone who would try to hack you). But you need to turn of custom errors for now, to get closer to the problem.

Oct 16, 2010 at 7:43 PM

 

Server Error in '/' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

Source Error:

Line 6:        <error statusCode="404" redirect="Renderers/FileNotFoundHandler.ashx" />
Line 7:      </customErrors>
Line 8:      <compilation debug="false" targetFramework="4.0">
Line 9:        <assemblies>
Line 10:         <add assembly="System.Security, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />


Source File: d:\web\localuser\petercardel.dk\c1\web.config    Line: 8


Version Information: Microsoft .NET Framework Version:2.0.50727.3615; ASP.NET Version:2.0.50727.3618

<!-- [ConfigurationErrorsException]: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive. (d:\web\localuser\petercardel.dk\c1\web.config line 8) at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags) [HttpException]: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive. (d:\web\localuser\petercardel.dk\c1\web.config line 8) at System.Web.HttpRuntime.FirstRequestInit(HttpContext context) at System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) --><!-- This error page might contain sensitive information because ASP.NET is configured to show verbose error messages using <customErrors mode="Off"/>. Consider using <customErrors mode="On"/> or <customErrors mode="RemoteOnly"/> in production environments.-->
Coordinator
Oct 16, 2010 at 9:36 PM

The website you published to is running "old .NET" and not .NET 4. You should contact the people hosting your site and ask them to "upgrade" your site to asp.net 4 (send them this link http://docs.composite.net/C1/Getting-started/System-Requirements.aspx )

Did you publish to a web hotel that WebMatrix suggested or did you publish to your own? If WebMatrix suggested I'd like to pass this info on - it should of course only suggest asp.net 4 enabled web hosting.

Oct 20, 2010 at 7:36 PM
Problem solved...thanks :-)