Edit Page functionality sketchy?

Topics: Troubleshooting
Oct 20, 2010 at 6:21 PM

Hello guys,

First I would like to say that I am really digging the look and philosophy of Composite C1 :)

Now on to my issue/question...

Yesterday I used Webmatrix to install C1 on my local machine. That went fine, no problems. I fired it up (as an aside, please please get it working in Google Chrome. Really is the best browser, IMHO) with no problems and looked around at various features in various perspectives. All good so far.

I decided I would take a look at the editing functionality so I chose the About Us page in The Composite C1 Demo Company website and clicked Edit Page. 

The tab for that page does appear with the four tabs (Settings, Content, Metadata and Preview), however the rest of the content never loads. All I get is the Windows Spinning Icon of Doom. To do anything else, I have to close the tab and reload. Bah.

I also Added a Page and the same effect occurs.

I have tried this in both Firefox (latest) and IE8.

Any suggestions? 

I am really looking forward to seeing if this will suit my needs. 




P.S. I am following your efforts on Stack Exchange as well and I am rooting for you all! :)

Oct 20, 2010 at 11:53 PM

Ok, so I have an update...

I downloaded the source and opened the solution in VS2010 and ran it. Everything worked fine, including the editing of content. So, I tend to think that perhaps something may be a little off with IIS or something. I am not really sure what could be causing the problem, but I am happy to see that I am able to continue my exploration of C1. 

Still liking what I am seeing. :)




Oct 20, 2010 at 11:57 PM

This could be a WebMatrix beta 2 issue - I have experienced a similar situation once on a single machine. Using firebug it looked like requests just fell into a black hole when hitting the server. Since we are now two experiencing this I will dig further. Thanks for providing good info and updates, and thanks for the kind words :-)