Can not install Composite.Tools.oData package to composite.

Topics: Standard packages, Troubleshooting
Nov 19, 2010 at 1:33 AM

    I've download the Composite.Tools.OData package. and installed to Composite C1 2.0 SP1 (Build no. 2.0.3974.29584) . But an message appear "Package installation failed The package composite version requirements does not match the current composite version". How can i install Composite.Tools.OData package to Composite C1 version 2.0 Sp1 ?
  

"

 

Nov 19, 2010 at 10:26 AM

We have new version of Composite.Tools.OData uploaded just few minutes ago with fixes for Composite C1 2.0 SP1. Please try again with new version.

Jun 4, 2012 at 6:07 PM

This seems to be the case with the latest 3.2.
Downloaded the Odata package from http://docs.composite.net/Data/OData

Failed with the message at the top.
Looked inside the install.xml and it reads:

<mi:PackageRequirements minimumCompositeVersion="2.0.3898.29851" maximumCompositeVersion="2.9999.9999.9999" />

If I change this setting to allow 3.2.4497.34793  will it cause any problems ?

 

Developer
Jun 5, 2012 at 6:51 AM

Hi webasylum

webasylum wrote:

...

<mi:PackageRequirements minimumCompositeVersion="2.0.3898.29851" maximumCompositeVersion="2.9999.9999.9999" />

If I change this setting to allow 3.2.4497.34793  will it cause any problems ?

No, it won't. Please either change maximumCompositeVersion to "9.9999.9999.9999" or re-download the package from http://docs.composite.net/Downloads/Composite.Tools.OData.zip  (the updated version with the above fix is online now)

Sorry for inconveniences

/Vitaly

Jun 5, 2012 at 4:40 PM

Thank you Vitaly for the reply :)