httpRuntime maxRequestLength="20480

Topics: Troubleshooting
Feb 6, 2011 at 1:46 PM

How I can install Composite CMS if upon installation process (at the beginning)
I get this error message? I am running it on a web hosting ASP.NET 4, Full Trust,
Windows Server 2008.

Thank you!

Feb 6, 2011 at 2:49 PM

Could you please provide more information about error? as far as I see from your message you have syntax fout by not closing "20480  <---- by quotation mark :)

The context of error is very important to understand the issue.So three lines above ,three lines below error and we can talk more about.....

Feb 8, 2011 at 12:58 AM
Edited Feb 8, 2011 at 1:11 AM

I want to say thanks for your reply because am so willing to try Composite for my future web designing.
Of course... any further detail I can publish may be relevant. This happens right away, not even a little step of Installation occurs.

I reinstalled Composite today in the same hosting after a complete reset: I am afraid such error was because the change between ASP.NET 2/3.5
despite shown in the control panel had not really been activated, probably I should have waited some time after the switching.

So now ASP.NET 4 Full trust has been activated fully and I do not have such error any longer but GOSH.... this is what I have now:

404 - File or directory not found.The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

I want to say that COMPOSITE was dropped for installation in the WWW not in a subdomain.

This version of COMPOSITE is:

I hope is the right one for web deployment!!!      here is CompositeC1 CMS



Feb 8, 2011 at 1:35 AM

well, somethings is obviously not configured right. and i believe you when you say that Composite was extracted to your domain, coz i can without problem access ie. It seems more like a configuration error of IIS, not allowing it to execute .aspx files or .Net in general since is not working either.

Feb 8, 2011 at 2:23 AM

.NET 4.0 is either not registered in IIS, or it is disabled. Usually I do the following:

1) Open .net installation folder, something like C:\WINDOWS\Microsoft.NET\Framework64\v4.0.xxxxx 

and run "aspnet_regiis -i"

2) Enable 4.0 in IIS

IIS 6.0

IIS 7.0

Feb 8, 2011 at 3:10 AM

I already realized... suspected that IIS could not process .aspx files but since it is a real ASP.NET hosting I thought to be wrong.

I do not have control on IIS myself, need to report this to the Hosting Provider guys and will let ya know what I have as reply.

I have other domains active by the same provider and I tried CompositeC1 there too, with the same result.

Appreciate your help and will let ya know. ::)) Thanking ya froom ITALY!



Feb 8, 2011 at 5:27 AM


Integrated Mode: this is what the Hosting Provider in Canada promptly activated for me. I sent them what I learned from you here,
in your posts to my trouble. I owe isqsolutions a lot as to performance but have to thank you first for your support and kind suggestions.

INSTALLATION OF COMPOSITE C1: I could then start and complete the installation of CompositeC1. It  was smooth as I have never seen before in life!

Then now..... YYYYAAAAYYYY! I am rushing to play with CompositeC1!!! See you later guys!