Error installing packages

Topics: Troubleshooting
Feb 15, 2011 at 12:22 AM

Hi all,

 

I'm having problems installing the package for the newsletter, event calendar and FAQ. 

Here's the error for the newsletter:


"Could not find install fragment type 'Composite.Core.PackageSystem.PackageFragmentInstallers.PackageLicenseFragmentInstaller, Composite'
XPath: /PackageInstaller/PackageFragmentInstallers/Add[1]@installerType"

The error is different for all 3 packages but this one is the smallest.  I've been able to install a few other packages successfully.  

Any idea what's causing the issue?

Thanks,

Markm    

Coordinator
Feb 15, 2011 at 4:41 PM

Hi Mark

Which version/build of C1 are you using?

Feb 15, 2011 at 11:36 PM

Hi Napernik,

Here is what the site says:

Composite C1 2.0 SP1
Build no. 2.0.3947.24461

Thanks,

Mark

 

 

 

Coordinator
Feb 17, 2011 at 11:16 AM

Hi Mark

Sorry for the late answer. Those packages require a newer version of C1 than currently released. 

You can get a beta version either by getting sources from http://compositec1.codeplex.com/SourceControl/list/changesets

Or, if you're using Web Platform installer, you can get the "how-to" instructions here http://community.composite.net/C1/Blog.aspx/2010/12/06/Preview-the-latest-beta-builds-of-Composite-C1