default website not showing logo or splash image

Topics: Troubleshooting
Mar 9, 2011 at 8:38 PM

Has anyone had any problems with the default omnicorp website not showing the logo and the splash images? For some reason everything looks great on my development computer and as soon as I publish everything to my web server the images fail to display. I am just running the default demo website. I have made no changes to it at all. The server I am hosting the site on is iis6.

Mar 9, 2011 at 8:47 PM

I guess you run the website in a sub folder when publishing? The OmniCorp demo come with a few CSS settings that break when running in a sub folder.

Mar 9, 2011 at 8:58 PM

Problem solved. I was hosting the site from inetpub\wwroot and once I moved the site to c:(root) everything worked fine. Thanks.

Mar 9, 2011 at 9:37 PM

If you have your IIS site mapped to serve content from "C:\" (and all sub folders) you may want to change that - sounds like a gigantic security hole.

Mar 9, 2011 at 9:43 PM

Just to follow up - the folder containing your website can reside anywhere without problem (although C:\ is definitely not something I would recommend) - but if the website folder is mapped as a 'virtual application' in IIS (i.e. you reference it using http://localhost/MySubFolder/default.aspx rather than http://localhost/default.aspx) then the CSS issues with spash images become visible. You do not need to move the physical folder hosting your website to fix this - you just need to map the IIS site root directly to your Composite C1 folder.

The OmniCorp demo site we will release as part of Composite C1 2.1 should run fine in both IIS root and a virtual application folder.

Mar 9, 2011 at 9:53 PM
Edited Mar 9, 2011 at 9:54 PM

ldoran... one way you can can do this is by changing the port and running the application from a root folder in iis7.


Like so:

Then you can access your site like so: http://localhost:8080/