Line breaks in WYSIWYG editor

Topics: Troubleshooting, Visual editor
Mar 24, 2011 at 12:19 PM

The WYSIWYG editor doesn’t put in line breaks. For example if I make a paragraph break in the text it looks good in the WYSIWYG, but then when I publish pages or preview them, the line breaks are gone. This is of course useless, so I have resorted to putting in breaks in the code <br />. But composite is stripping this code when I open or edit the file again, which forces me to manually do the breaks again.

Coordinator
Mar 24, 2011 at 12:20 PM

What version are you running? You can find this information in Help | About.

Mar 24, 2011 at 12:51 PM


Here is the info.        
     
Composite C1 1.2 SP5

    
Build no. 1.2.3840.21244

Coordinator
Mar 24, 2011 at 1:32 PM
Edited Mar 24, 2011 at 1:33 PM

That is a "pre-open source" release, so this may not be relevant to the current 2.1 release.If you provide me with a "steps for dummies" guide on keys you press, and what happens/was expected I can check if this is an issue in the latest release and let you know if an upgrade would solve your issue. The visual editor have undergone multiple changes since the 1.2 release so chances are pretty high.

If I understand the issue correctly you press SHIFT+ENTER (generating <br /> tags) or write explicit <br/> tags in the source code and these are removed. As far as I remember the visual editor (Tiny MCE) in 1.2 generated <p /> elements with <br/> in them fairly unmotivated, and a choice of silencing this behavior was taken to avoid documents getting 'blank areas'. This would account for your experience.

Perhaps you can use this: If you want this to create some large spacing between paragraphs, perhaps using a "class" and a simple css rule like p.topspaced { margin-top: 4em } could be used - you can add this "topspaced" option the the style drop down - so instead of the users pressing SHIFT+ENTER to obtain some 'visual' effect, they select "topspaced" from the style dropdown in the toolbar.

Jun 20, 2013 at 1:08 PM
Many systems will use Ctrl+Enter for hard line breaks. That was what I tried instinctively.

It would be good to have this key mapping as well.