Can't Access my Composite C1 Interface

Topics: Troubleshooting
May 9, 2011 at 2:33 PM
Edited May 9, 2011 at 2:34 PM

Hi guys, 

I had this strange issue, my sites with composite C1 installed are like this:

http://host/appname1/project1 and http://host/appname2/project2

I'm accessing my Composite C1 using:

http://host/appname1/project1/Composite and http://host/appname2/project2/Composite

after installing the fix for NicerURL Our composite isn't accessible anymore using the links above, I didn't remember changing anything except installing the NicerURL package.

you can check my sample website 

here

Regards,

Arnel Gracela

May 10, 2011 at 12:23 AM

Heh, thats an interesting issue... its in fact due to the latest addition made per request to support PathInfo urls. What happens here is that duragrass/Composite is not recognized as a valid page so we tro to remove the Composite and see if duregrass is a valid page. It is, since its the root, so we decide to render that and append Composite as PathInfo to that page.

The fix should probably be something like, that if the url, minus application-path = Composite, then skip the NiceUrl thing and just render as normal page. Ill have that up for later. 

May 10, 2011 at 5:32 AM

yeah, and btw, if i access something like this http://host/appname1/appname1/appname1/appname1/(anything here) it's being render as the root page.

I'll be waiting for the fix.

Thanks and Regards,

Arnel

May 10, 2011 at 10:43 AM

well, that is by design and what was asked for here http://compositec1contrib.codeplex.com/discussions/255920... what else would you expect?

May 10, 2011 at 1:41 PM

so maybe the implementation of PathInfo support is a bit too aggressive. What i can do instead is to make it possible to configure which pages i C1 you want to enable this functionality for and how many levels the backtracking should work on.

May 10, 2011 at 3:50 PM

ok, so is it possible for my webapplications to access the composite using http://host/webapp1/composite?

Regards and appreciate the effort,

Arnel

May 15, 2011 at 4:03 PM

Hi Arnel! Sorry for my late reply, i have been in the process in moving to Copenhagen. I have had a look at it now though. At first i couldn't reproduce but it turned out only to be a issue when running Composite in a virtual directory.

The latest check in allows you to access the Composite admin interface again http://compositec1contrib.codeplex.com/SourceControl/changeset/changes/66835.

May 16, 2011 at 11:12 AM

Hi burningice,

Works perfectly, Thank you very much.

Regards,

arnelgracela

May 18, 2011 at 11:11 AM

Composite package server also updated with fresh version of Contribution.CompositeC1Contrib.Core