Changeset 7423+ breaks Contrib project

Topics: Release notes
May 25, 2011 at 7:59 PM

Any users of the CompositeC1Contrib project - Masterpages, SiteMapProvider, NicerUrls etc. should not upgrade to changeset 7423+ since it breaks compatibility and there seems to be no plans from the Composite Devs to change this and make sure that ie. Masterpages can continue to be supported.

Sure, support can always be achieved by making custom builds of the source, but as a package its no longer possible to use it.

Coordinator
May 26, 2011 at 7:12 PM

Intermediate (not release/recommended) builds aren't safe to use, since they aren't fully tested, and can break compatibility not only with contribution projects but even with some of our own modules. So, the only safe way to upgrade is to wait for the next recommended version & related upgrade instructions.

We're planning to have functionality similar to CompositeC1Contrib's NicerUrls & SiteMapProvider to be done soon; those who are using master page support now, shouldn't be worried, we are going to have some API/configuration for replacing default C1 page rendering, so new versions of CompositeC1Contrib could plug-in master pages support.

Jun 17, 2011 at 4:12 PM

For those who want to be using the newest version of Composite C1 together with the Contribution project should worry no more... go and upvote this issue http://compositec1.codeplex.com/workitem/739 which even includes a patch to the core to continue supporting hijacking of the page rendering.

Coordinator
Jul 6, 2011 at 2:37 PM

Compatibility was fixed in changeset 7942 

Jul 6, 2011 at 3:11 PM

And latest checkin is compatible with changeset 8173