"Outbound HTTPS/SOAP connection" error

Topics: General, Troubleshooting
May 26, 2011 at 7:24 AM

Dear Sir,

I've downloaded Composite using webmetrix on IIS7.5
Currently I'm facing the error of "Outbound HTTPS/SOAP connection"
I've configured the proxy in webconfig
I've also tried the code in the link  (http://compositec1.codeplex.com/discussions/253005) where you will create a file called ping.ashx, the output is below
I'm still getting the same error
"Outbound HTTPS/SOAP connection", could you help me to solve it.

Server Error in '/CompositeC1' Application.

The remote server returned an error: (502) Bad Gateway.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Net.WebException: The remote server returned an error: (502) Bad Gateway.

Source Error:

The source code that generated this unhandled exception can only be shown when compiled in debug mode. To enable this, please follow one of the below steps, then request the URL:

1. Add a "Debug=true" directive at the top of the file that generated the error. Example:

  <%@ Page Language="C#" Debug="true" %>

or:

2) Add the following section to the configuration file of your application:

<configuration>
   <system.web>
       <compilation debug="true"/>
   </system.web>
</configuration>

Note that this second technique will cause all files within a given application to be compiled in debug mode. The first technique will cause only that particular file to be compiled in debug mode.

Important: Running applications in debug mode does incur a memory/performance overhead. You should make sure that an application has debugging disabled before deploying into production scenario.


Stack Trace:

[WebException: The remote server returned an error: (502) Bad Gateway.]
   System.Net.HttpWebRequest.GetRequestStream(TransportContext& context) +6022589
   System.Net.HttpWebRequest.GetRequestStream() +13
   System.ServiceModel.Channels.WebRequestHttpOutput.GetOutputStream() +59

[EndpointNotFoundException: There was no endpoint listening at https://package.composite.net/Setup/Setup.asmx that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.]
   System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) +9464367
   System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) +345
   Composite.Core.WebClient.Setup.WebServiceClient.SetupSoap.Ping() +0
   PingTester.ProcessRequest(HttpContext context) +30
   System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +100
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75



Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

May 26, 2011 at 8:29 AM

Hi!
First of all try this simple solution: http://forums.asp.net/t/1311835.aspx/1?The+remote+server+returned+an+error+502+Bad+Gateway+

If no luck - try this: http://docs.composite.net/C1/Getting-started/Setup-check-failures.aspx?errors=connection