Updating metadata data type does not update on content pages

Topics: Troubleshooting
Jun 22, 2011 at 11:24 AM

When I edit a metadata data type and change one of the labels for a field, for example, the update is not shown when editing a content page where the metadata type is already added.

Example:

Create a metadata data type
Add a field
Add the metadata data type to a page type
Create a content page with the same page type
Fill out the metadata field
Edit the metadata data type and change the label or help text and save the changes
Edit the page created just before and open the metadata tab

Result: The label has not changed.

Is this a cache issue?

I tried restarting the server, but that didn't change it. The only way I found to update it, is to remove the metadata data type from the page type, and then add it again. But this is not a viable way, because then I lose all the metadata on all the pages which has the metadata data type.

Surely, there must be a way to update these strings without having to remove and re-add the metadata data type?

Jun 22, 2011 at 12:33 PM

Hi reneg,

I tried your scenario on v 2.1.1 and on the latest beta 2.1.3.

If I change both Label and Help Text in the meta type, and then re-open the page (that uses page type with this meta field), the field's label and help text change accordingly.

I am afraid I can't reproduce the issue you have described.

Am I missing some important detail here? Could you please tell what version of C1 you are using? Is it XML or SQL-based? etc

Thank you in advance

/Vitaly

 

 

Jun 22, 2011 at 1:10 PM
Edited Jun 22, 2011 at 1:11 PM

Still trying to figure out what's going on... :)

1. Did you (or anyone else) - by chance or on purpose - "Edit Form Markup" on this meta type?

If you have edited the metatype's form markup or at least opened it and saved it,
then in the /App_Data/Composite/DynamicTypeForms folder, there will be an XML file with your metatype's form markup. (Say, your meta type is called "My.Test.Metatype" so you can find its form markup as /App_Data/Composite/DynamicTypeForms/My/Test/Metatype.xml)

As long as this file exists, whatever you change in your meta type via the regular type editor, will be ignored.

2. Do you refer to the label of the field (on the Fields tab in the metatype editor)? Any chance you may refer to the label on the field group (the one you specify when adding the metafiled to the page type)?

Thanks in advance,

/Vitaly

Jun 22, 2011 at 1:35 PM

Thanks for helping me out with this.

I checked the folder you mentioned to see if there was any XML files, but the folder was empty. I haven't changed anything about the form markup.

The website I'm working on is XML based.

My build is 2.1.4113.99. Maybe I should try and update to see if that fixes the problem?

Jun 22, 2011 at 1:47 PM

Arrg! You're right! :-)

I'm so sorry, your second point was right on the money. The problem was with the label on the field group, which I edit on a per page type basis, and not on the metadata type.

I tried changing the label there, and then it correctly updated.

Sorry for wasting your time. :-/

Jun 22, 2011 at 1:50 PM

Great! :) Glad  it helped

P.S. Actually, it was mawtex's guess :)