Not all media files is listed when inserting media url

Topics: General, Visual editor
Jul 10, 2011 at 8:56 AM

I have uploaded a flv, swf and a wmv file into my medie archive.

When going to edit a content page, i switch to source mode. Click that I will like to insert a media url.

Now only my swf file is listed.

I'm using version

Composite C1 2.1 (BETA 5)
Build no. 2.1.4071.37714

 

Coordinator
Jul 11, 2011 at 8:42 AM

Hello,

Strange behavior as all these formats should be listed and we couldn't reproduce this.

Try to clear browser cache and try again.

Also you can try to upgrade your BETA version to the official release   - just follow steps described here - http://compositec1.codeplex.com/discussions/255955

Coordinator
Jul 11, 2011 at 10:48 AM

Upgrading to 2.1.1 is a must (it is quick and you would have to do it at some point anyway), but it will not likely help you solving the issue.

Try the following: if the site is running on XML, open file "~/App_Data/Composite/DataStores/Composite.Data.Types.IMediaFileDatas_public.xml",

find your file there, and check what is the value of MimeType attribute, it should be "video/x-ms-wmv" 

Jul 11, 2011 at 4:14 PM

I tryied to follow the guid, and use the stable release.

But after upgrading all my created metadata did not work.

And I cut not edit a page.

After rolling back, the files in my list.

Are there any plugins for inserting movies(not flash, i know this one :-) )

Jul 11, 2011 at 6:15 PM

A funny opservation.

If I insert a flashmovie(plugin installed in the packeds), and then will insert a media url, then only flash files is listed.

It is like the filter from flash i still on.

Coordinator
Jul 11, 2011 at 6:46 PM
Edited Jul 11, 2011 at 6:53 PM

I reproduced your problem. Composite.Media.FlashViewer function has FlashFile input parameter which uses MediaFileSelector widget with file extension filter to select only .swf  files.

Somehow MediaFileSelector widget memorise this filter when you use it while trying to insert  Composite.Media.FlashViewer and then you can not insert media urls to other media files by using Page Content  -> Insert Media URL.

It is a bug and I will report it.

As workaround try to refresh your C1 console in browser by pressing F5.

Coordinator
Jul 12, 2011 at 8:53 AM

>> But after upgrading all my created metadata did not work.

When and if you will be trying to upgrade it again, try to fix metadata with the steps described here http://compositec1.codeplex.com/discussions/232780 , we will solve this issue in later versions.