Admin Console not starting up

Topics: Troubleshooting
Aug 11, 2011 at 5:45 AM
Edited Aug 11, 2011 at 5:49 AM


I cannot log in to the Composite back end. The CSS is all over the place and I cannot see the user name and password box. When I look at the firefox error log , I get the following message "error parsing value for 'filter' for a facebook plugin called likebox.php.

Any ideas what could be causing this?

Aug 11, 2011 at 8:56 AM

Any chance you can send me a screen shot (maw at or put it online somehow? If you have any debug goodies from Firebug that would be a great help also. Versions of browser and C1 also.

The start screen inside the C1 Console is currently displaying a Facebook Like Box - we are trying to advertise our newly launched Facebook page to reach a "softer audience".

Aug 11, 2011 at 3:46 PM

I found the cause of the error and (as is usually the case) it was a bit of stupidity on my part! At some point I must have dragged-and-dropped the "styles" folder in the composite directory to another folder by mistake. I moved the folder back to the correct location and the problem was sorted out. I only picked this up after deploying the website to another machine. On my dev machine, the cache folder obviously had a precompiled version which meant that it worked locally.

One thing I'm still not sure about is which folders to exclude from source control. I currently exclude the Cache and ApplicationState. I would expect deleting these folders would be ok (e.g. when a new developer gets the website out of source control). Should the DataMetaData folder be under source control? If I delete this folder (to simulate a fresh copy from source control), it does automatically get recreated, but I cannot browse the tree in the back-end after this. I get node errors when the site map tree is building. So I'm assuming this folder should be under source control?

Thanks for the quick response.



Aug 11, 2011 at 9:37 PM

DataMetaData should be under source control - all the dynamic types are defined here, so deleting this folder is basically killing a big part of your data schema.

Aug 12, 2011 at 4:35 AM


I added the DataMetaData folder back into source control, and this uncovered one small issue that may be a bug in the system. I compared the different versions of the DataMetaData folder on various developer machines in order to get the latest version under source control. I noticed that the date/time format used in the xml files in this folder are machine specific. I have an Australian date/time setting and another developer has a US date/time setting, so when I compared the folders, I found that the data was inconsistent. Below is an example from the IMediaFileData_<guid>.xml:

Machine 1     <DataFieldDescriptor id="d9095572-6a08-4115-999a-b70a449c827e" name="CreationTime" ... defaultValue="ValueType='DateTimeNow'Value='12/08/2011\ 10:42:04\ AM'">

Machine 2    <DataFieldDescriptor id="d9095572-6a08-4115-999a-b70a449c827e" name="CreationTime"  ...defaultValue="ValueType='DateTimeNow'Value='8/3/2011\ 4:32:49\ PM'">

Both these date/times where in August. You can see the day first in the first machine and the month first (US format) in the second machine.

Would this be an issue??

PS: Thanks again for a great product. We're loving it...


Aug 12, 2011 at 11:22 AM

>> Both these date/times where in August. You can see the day first in the first machine and the month first (US format) in the second machine.

It's a bug, will be fixed soon

Aug 13, 2011 at 12:43 PM

Thanks, thats good to hear!

Do you have a release date yet for the next version?



Aug 13, 2011 at 4:56 PM

We hope to have a release candidate in about three weeks.

Aug 15, 2011 at 4:07 PM
Edited Aug 15, 2011 at 4:19 PM

>> Would this be an issue??

No. Because even though current date is serialized, that serialized value never used. But rather DateTime.Now will be executed every time

defaultValue="ValueType='DateTimeNow'Value='12/08/2011\ 10:42:04\