Composite.Community.Blog

Topics: Standard packages, Troubleshooting
Sep 19, 2011 at 8:07 AM

Hello,
blogging by creating pages and insert the post, this post is not displayed. His header is normally seen on the blog site, but after clicking on your own post on the page does not appear anything. What's wrong? Thank you in advance for your reply. Sorry for bad English;-).

Sep 19, 2011 at 8:17 AM

Hello,

Could you specify more details, f.e. :

- C1 version (Help->About Composite C1 )

- Blog package version (System -> Packages -> Installed packages->locate package -> Package Info)

- do you use CompositeC1Contrib , NicerUrls ?

- server configurations (OS, web server)?

Sep 19, 2011 at 8:28 AM

- Composite C1 2.1.1 Build no. 2.1.4113.99

- 1.6.6

- CompositeC1Contrib

- W7 64 Bit(6.1 7601), IIS 7.5.7600.16385)

Sep 19, 2011 at 8:50 AM
Edited Sep 19, 2011 at 8:52 AM

Probably the problem with your CompositeC1Contrib.dll version + C1 blog package. I am not sure, but I think this contrib change set  http://compositec1contrib.codeplex.com/SourceControl/changeset/changes/66500 contains necessary fix. Try to get this version of CompositeC1Contrib and recheck the Blog.

You can try to disable CompositeC1Contrib NicerUrls feature to make sure that it is the issue. Edit web.config locate section:

<modules>
    <add name="UrlFilter" type="CompositeC1Contrib.Web.UrlFilterModule, CompositeC1Contrib" />
</modules>

comment UrlFilter module, restart your application, then check Blog functionality - it should work.

Sep 19, 2011 at 9:27 AM

Thank you very much,
helped commented in Web.config. I'm not a programmer so I had a problem with the integration of changes to C1. In the Czech Republic say - thank god;-).

Sep 19, 2011 at 9:43 AM

>> I'm not a programmer so I had a problem with the integration of changes to C1.

How to get CompositeC1Contrib change-set #66500:

- download this change-set, there is Download link at the top - http://compositec1contrib.codeplex.com/SourceControl/changeset/changes/66500

- locate file - \compositec1contrib-66500\Core\bin\Release\CompositeC1Contrib.dll and put it to the bin folder of your site (replace existent .dll)

- switch back CompositeC1Contrib NicerUrls feature and re-check Blog.

Sep 19, 2011 at 10:23 AM

On the local PC with a new one. DLLs does not work at all-error. On the website, although it works, but the problem persists;-(.

Sep 19, 2011 at 11:57 AM
Edited Sep 19, 2011 at 12:19 PM

I find that the local PC it works if the title of the blog is written by Czech characters. However, the website problem persists. There click on the link blog does not own a blog, but only a basic list of contributions.