Error on Windows Server 2008

Topics: Troubleshooting
Oct 7, 2011 at 9:13 AM

Hi,

I never had problems installing or running C1 on my Windows Server 2003.

Now I have a new Windows Server 2008 and I get error during install - the rights are ok, I think.

Then I tried to get a demosite from my localhost running on this server. I uploaded the complete directory but when I open the site I get the following error:

Compilation returned error "Could not write to output file 'c:\inetpub\vhosts\sitepunkt.net\httpdocs\App_Data\Composite\Cache\Assemblies\CMS_63DD8928_B4EB7FC0_v0002_50b98b1a-b7a6-4eab-bfa4-d24d800184ca.dll' -- 'Der Prozess kann nicht auf die Datei zugreifen, da sie von einem anderen Prozess verwendet wird. '", File: "", Line: "0"

The errors message during install was similar.

It means the process cannot access the file because it is in use from another process.

Any ideas ?


Thanks,

Thorsten 

 

Oct 7, 2011 at 9:19 AM

Sounds like two different processes are having a go at the same file. If you have multiple servers/sites pointing into the same folder (like having both IIS and VS2010's web server host the same folder site) then stop one of them.

If you experience this with a single IIS, you probably have to stop and restart IIS.

This is something we are currently working on fixing.

Oct 7, 2011 at 9:32 AM

I experience this with a single IIS - only PLESK is also running on this machine - and it's a virtual Server powered by Parallels Virtuozzo Containers.

Will reboot and try again...

 

Oct 7, 2011 at 9:42 AM

Reboot and no changes :-(

But I found this thread here: http://compositec1.codeplex.com/discussions/258784

That's exactly my problem.


Oct 7, 2011 at 9:46 AM

Now I stopped and started IIS - the next message:

Server Error in '/' Application.

The file 'C:\Windows\TEMP\u0jpjkt2.out' already exists.

Oct 7, 2011 at 9:48 AM

Another stop and start of IIS - again another message:

Server Error in '/' Application.

Compilation returned error "Could not write to output file 'c:\inetpub\vhosts\sitepunkt.net\httpdocs\App_Data\Composite\Cache\Assemblies\CMS_89BDDCBD_F89F99BC_v0002_ecc3a08d-0406-449a-9ac0-944f9aab20dc.dll' -- 'Der Prozess kann nicht auf die Datei zugreifen, da sie von einem anderen Prozess verwendet wird. '", File: "", Line: "0"



 

Oct 7, 2011 at 10:06 AM

If you have something like this in your web.config

<compilation debug="true" targetFramework="4.0" optimizeCompilations="true">

Try change the debug and/or to optimizeCompilations to false. If it works, you can change it back to true.

Oct 9, 2011 at 8:41 PM

Hi,

I did some testing with a local W2K8 and an Amazon EC2 VM - no problems installing and running C1.

After some research this weekend I have come to the conclusion that the cause for my problems with this special server is the fact, that this machine runs as Parallels Virtuozzo Container.

Maybe this could also be the cause for the problems of 'arnelgracela' here: http://compositec1.codeplex.com/discussions/258784 - if he lets his machine run on Virtuozzo


So no problem with C1 at all :-)